This project has moved and is read-only. For the latest updates, please go here.

Test Aggregation Performance Error...

Topics: Resolved
Sep 22, 2011 at 12:15 AM

Hey All,

I'm getting the following error when using the Test Aggregation Performance tool on the Aggregation Manager:

"No processed aggregations found in cube MyCube on database MyDB on server MyServer."

I found another thread on this discussion board that addresses this issue (, but the solution there does not resolve my issue.  I can see the aggregations processed on the server using this method:  (  I've processed the indexes.  I've processed the Cube in full.  Still nothing.

I used this tool successfully before on another cube I built not a few months ago, but now I get this same error even on that old Cube it once worked on.  I have made some security changes to the deployment server in terms of additional roles and I did upgrade to version 1.5 of BIDS Helper.  I reinstalled the old version of BIDS Helper and removed those security changes, but the tool still does not work.  Any ideas or suggestions?  I'm a bit stuck at this point.  Is there some kind of connection or security setting in Visual Studio that I'm missing?  Thanks!

Sep 24, 2011 at 3:36 PM

Sorry you're having problems. Let's see if we can figure out what's going on.

When you connect to SSAS in SSMS and right click on each database, does the ID match the Name? (I'm wondering if there's a bug in BIDS Helper and it's looking at the wrong database.)

If that's not it, can you start Profiler connected to SSAS then run the Test Aggregation Performance tool, then save the Profiler trace to a .trc file. Then please start a new issue on the Issue Tracker tab and upload the .trc file. Hopefully that will help us get to the bottom of this issue.

Oct 4, 2011 at 10:00 PM

Okay, I got it working again.  Apparently it was an issue with a cartesian join that was occuring as a result of one of my many-to-many Dimensions.  Because it was creating multiplied records, the cube processing seemed to be skipping the creation of aggregations.  That link I posted earlier on checking that your aggregations exist is wrong.  My cube in fact did not have processed aggregations as BidsHelpter was indicating to me.  So please close this issue as it was specific to my own cube design.  Thanks!

Oct 4, 2011 at 10:09 PM

Thanks for getting back to us. I'm glad that you identified your issue.

Oct 4, 2011 at 11:31 PM

Can I ask what your issue was with the post about checking if your aggregations are processed? If there is something that is unclear or not working I would like to try to fix it.