Deploy SSIS Packages - no Deploy (BIDS Helper) tab?

Topics: Resolved
Aug 26, 2008 at 5:55 AM
Edited Aug 26, 2008 at 5:56 AM

I have BIDS Helper 1.3.0.6 installed and other new functionality is working (e.g. Sort Project Files). 

I can see the new Deploy item in the SSIS Solution right-click menu. However the Solution property pages window does not show the new Deploy (BIDS Helper) tab - I'm stuck. 

I've tried creating a new Solution and editing and existing one - same result.

Any ideas?

Thanks
Mike

PS: great work on the new release guys - thanks for your continued efforts.

Coordinator
Aug 26, 2008 at 1:47 PM
This appears to be an issue with the 2005 build. I think I have found the issue and have updated the 2005 builds to v1.3.0.7. It would be great if you could check it out and let me know if it works for you.
Coordinator
Aug 26, 2008 at 8:51 PM
One of the other guys on the BIDS Helper team said that my "fix" broke the feature for him, so it looks like this issue is not full resolved. It all hinges around detecting that the user clicked on "Properties" without using the caption of the menu item as that changes in non-english versions of BIDS. We are currently investigating another approach that looks promising.
Aug 26, 2008 at 10:43 PM
Hi, I was having this issue but didn't seem to have any of the BIDS Helper functionality. I then downloaded and installed the version uploaded on the 20th of August and after a restart I then seemed to have all the options available in the properties menu.
Coordinator
Aug 27, 2008 at 12:46 PM
The code that was detecting the click on the properties menu and injecting the BIDS Helper configuration page did not appear to be completely reliable. In the new 1.3.0.8 release we are now using a different method to integrating this functionality which should be reliable.
Aug 28, 2008 at 1:02 AM
Hi Guys,
I just tried the 1.3.0.8 release on the same machine and it is working now - thanks for your efforts.
Mike
Nov 5, 2008 at 10:35 AM
Hi, Did these changes get rolled into the 2008 version?  I have the 2008 1.3.0.8 release and I can only see the deploy item when I right click an individual package, not at the project level and I also don't see the Deploy (BIDS Helper) option on the project properties.  This is working fine with the 2005 version.
 
Graeme
Coordinator
Nov 5, 2008 at 7:14 PM
Yes, these changes are in the 2008 version. We essentially have the one code base with a few minor conditional compile statements and we compile once against the 2005 dlls and once against the 2008 ones. I have both versions running side-by-side on my laptop. Have you had any prior versions of SQL 2008 or BIDS Helper 1.3 on this machine. I'm not really sure at the moment how this feature could be half enabled.
Nov 12, 2008 at 9:56 AM
I had Visual Studio 2008 installed, uninstalling this has resloved this issue. 
Coordinator
Nov 12, 2008 at 10:47 AM
Thanks for letting us know Graeme. This is still a little mystifying as the two versions should be able to run side by side. I have both SQL 2005 & 2008 on my laptop and I will have to go and double check that BIDS Helper is still working in both.
Nov 12, 2008 at 3:04 PM
Just to be clear I have both SQL 2005 and SQL 2008 installed and it is working fine, it is when I install Visual Studio 2008 (not just BIDS but the whole VS)  that it stops working.

Mar 3, 2009 at 9:20 PM
Hi, I have VS (BIDS) 2005 and BIDS Helper 1.4 installed and I have the same problem - the "Deploy" option is available when right-clicking on individual SSIS packages but Project properties is missing the options to set the BIDS Helper deployment settings. I was previously using BIDS Helper 1.3.0.8 and this was working correctly. Any ideas?

thanks, Nathan
Coordinator
Mar 6, 2009 at 6:00 PM
nathan76, when you say the Project properties dialog is missing that screen, how precisely did you get to the project properties dialog? Did you right click on the project node and choose Properties? (There are other ways to get to that dialog, but we only show the BIDS Helper deployment settings screen when you get to it as described above). Let us know if that was your problem.
Mar 9, 2009 at 12:20 AM
Edited Mar 9, 2009 at 12:22 AM
Hi,

To get to the dialog I was right-clicking on the project node in Solution Explorer and selecting "Properties". I've tried uninstalling and reinstalling BIDS Helper 1.4 but the problem persists.

cheers, Nathan
Coordinator
Mar 10, 2009 at 3:59 PM
We just checked in some changes to source code that fixed Nathan's problem. These changes will be in the release following 1.4
Coordinator
Mar 10, 2009 at 4:00 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Nov 21, 2009 at 10:44 PM

I've just checked in a change to the source code that will hopefully work for everybody. And if it doesn't, it will spit out a debug file to the following path which you can send us via attaching it to a new issue under Issue Tracker:
C:\Documents and Settings\<username>\Local Settings\Temp\BidsHelperDeploySSISPackagesPropertiesMenuDebugLog.txt

If you want a quick private build of this change to make sure it's working for you before we release this change, contact me.