BIML - Unable to create a Project Connection

Mar 8, 2013 at 10:50 AM
Edited Mar 8, 2013 at 10:50 AM
Hi, using the new BIDS 1.6.2 it seems that when I set the attribute "CreateInProject" to "true" in a Connection, eg:
<OleDbConnection Name="OLTP2" ConnectionString="Data Source=localhost; Initial Catalog=tempdb; Integrated Security=SSPI;" CreateInProject="true"/>
The Project Connection is NOT created in the project.

Is that the intended behavior (so this means that the Project Connection has to be created manually) or not?

Thanks a lot!
Apr 13, 2013 at 2:36 AM
Thanks for the help with the code for this fix, Davide. Just updating this thread to say that release 1.6.3 solves this issue (thanks to you).
Aug 10, 2014 at 2:32 AM
Is it working ?

I have been trying to use it in SQL2014/VS2013 but it's not working. It creates the connections in my package but i want them at the project level.
Aug 11, 2014 at 5:05 PM
Right now is not working 'cause the code (I just checked) check explicitly for Denali in order to enable the Project Connection support. I'll open an issue in order to have this fixed.
Nov 6, 2014 at 10:35 AM
Hi, I have the same issue using SQL2014 with VS2013. My project connections aren't created. Any update when this will be resolved?
Mar 2 at 3:15 PM
Hello, Is there a visibility on when is this likely to be resolved for SQL2014 and VS2013?
Mar 2 at 7:04 PM
We've been through a couple of rounds of testing on the BIML support for SQL 2014. I believe that this is back with Varigence to fix some other issues that were found in the updated BIML engine. Still no firm ETA, but progress is being made.
Mar 17 at 5:16 PM
Proper BIDS Helper Biml support for SSIS 2014 and Visual Studio 2013 has been released:

Please give it a try and let us know if you find any problems. I think it fixes the problem mentioned in this thread, so please retest. Thanks for your patience.
Marked as answer by furmangg on 3/17/2015 at 10:16 AM
Mar 17 at 9:11 PM
Retested and can confirm this works ok now. Brilliant work guys. :)