BIDS Helper and Visual Studio 2012

Sep 24, 2015 at 6:39 PM
I have Visual Studio 2010 and 2012 installed on my laptop. I've installed the latest version of BIDS Helper for SQL Server 2012.

BIDS Helper is visible in VS 2010, but BIDS Helper is NOT showing up in VS 2012.

I've reinstalled successfully several times and restarted my laptop and it still does not work.

Are there known issues with BIDS Helper and VS 2012??
Sep 24, 2015 at 9:53 PM
What was the install order between VS2010, VS2012, and BIDS Helper 2012? Hopefully that order.

Did you install SSDT-BI for VS2012? If you go in VS2012 to Help... About Microsoft Visual Studio do you see Analysis Services? BIDS Helper?

Did you use BIDS Helper setup or xcopy deploy?

If you go to Tools... options... BIDS Helper... Version do you see errors? Do you even see BIDS Helper there?
Sep 25, 2015 at 7:46 PM
Edited Sep 25, 2015 at 7:51 PM
I installed VS2010 and then VS2012. I then installed BIDS Helper

I THEN installed version, but when going into VS2102 it says I STILL have installed, even though the install completed successfully. I have restarted after each and every install.

And yes I have SSDT-BI installed for both versions.

And both Analysis Services and BIDS Helper show as being installed. I used the setup to install.

No errors when going into Tools >> Options >> BIDS Helper
Sep 25, 2015 at 7:48 PM
Where in VS2012 are you clicking and expecting BIDS Helper to show up? If you see it in Tools... Options it is running.
Sep 26, 2015 at 12:52 AM
Edited Sep 26, 2015 at 12:56 AM
It may say it is running in About >> or in Options, but it is not actually working. I've worked with BIDS Helper for years and the behavior it is exhibiting is not what it is supposed to be doing.

Yes, it shows up in Help >> About just fine.

But when I right click the SSIS project node in Solution Explorer and choose Properties, there should be the option to choose "Deployment BIDS Helper" as one of the properties you can modify. You choose where to deploy and what database to deploy to. That option DOES NOT show up in VS2012 or VS2013 Ultimate, even though VS2012 and VS2013 BOTH say BIDS Helper is installed.

It shows up fine in VS 2010.

Would you like me to attach pictures as to what I should be seeing and what I'm actually seeing?
Sep 26, 2015 at 1:07 AM
In VS2012 is your SSIS project in project deployment model or the legacy package deployment model?
Sep 26, 2015 at 2:16 AM
They are both in package deployment and have always been in package deployment mode.

Don't know how to insert an image into a post here, otherwise would show you exactly what I'm talking about.
Sep 26, 2015 at 2:40 AM
Is it just this project or does this happen with other projects? Can you try creating a brand new project in 2012 in package mode and see if that has the same issue?
Sep 26, 2015 at 2:54 AM
This happens with all projects and new projects...
Sep 26, 2015 at 4:24 AM
Edited Sep 26, 2015 at 4:25 AM
Did you do xcopy install? Uninstall BIDS Helper 2012 from Add/Remove Programs. Then launch VS2012 and see if it's gone. Once it's gone, install BIDS Helper 1.7.0.

If 1.7.0 doesn't work, can you post the contents of this file in this thread:
C:\users\<username>\Local Settings\Temp\BidsHelperDeploySSISPackagesPropertiesMenuDebugLog.txt

Unfortunately this issue has happened enough we already have debugging built in.

Do you have solution folders or anything other than a single project?
Oct 28, 2015 at 12:14 PM
Happens to me too but I have no such file at all (C:\users\<username>\Local Settings\Temp\BidsHelperDeploySSISPackagesPropertiesMenuDebugLog.txt)

Just installed Visual Studio 2012 on new laptop
Then BidsHelper (BIDSHelper2014Setup(

Tried to install "as Administrator"... no joy.

Nothing is visible anywhere.
Oct 28, 2015 at 12:22 PM

How embarrassing, I was using the wrong installation!!!

It works a lot better with BIDSHelper2012Setup( :-)